1.0  Apa itu SSL and TLS?
2.0 Apa perbedaan?
3.0 Apa perubahan?
4.0 Apa artinya bagi saya?
5.0 Apa resiko?
6.0 Apa yang bisa saya lakukan?

1.0 Apa itu SSL dan TLS?

SSL merupakan singkatan dari Secure Sockets Layer manakala TLS merupakan singkatan dari 'Transport Layer Security'. Kedengarannya menakutkan? Sederhananya, mereka adalah protokol keamanan yang paling banyak digunakan saat ini, yang memberikan privasi dan integritas data untuk menyimpan data anda dengan aman. 

Kata SSL dan TLS sering digunakan secara bergantian atau dalam hubungannya dengan satu sama lain (TLS/SSL), tetapi pada kenyataannya pendahulunya lain — SSL 3.0 menjabat sebagai dasar untuk TLS 1.0, sebagai akibatnya, kadang-kadang disebut sebagai SSL 3.1 (LuxSci, 2017). 

2.0 Apa perbedaan?

SSL 3.0 ini sudah semakin tua dan perkembangan terakhir, seperti POODLE vulnerability telah menunjukkan bahwa SSL 3.0 sekarang benar-benar tidak aman (terutama untuk situs web yang menggunakan). Sementara TLS 1.0 telah memiliki pangsa kerentanan, dan semakin banyak organisasi yang mulai mematikan ini sebagai pilihan untuk negosiasi enkripsi antara klien dan server. Gambar di bawah ini menunjukkan rilis tahun dan versi yang diluncurkan untuk SSL dan TLS. 

3.0 Apa perubahan?

SSL dan TLS telah di antara protokol enkripsi yang paling banyak digunakan selama 20 tahun, dan masih tetap digunakan secara luas hari ini meskipun keberadaan sejumlah ditemukan kerentanan keamanan.

Seperti yang disebutkan oleh National Institute of Standards and Technology (NIST), tidak ada solusi yang bisa memperbaiki SSL atau awal TLS. Akibatnya, itu sangat penting bagi organisasi untuk meng-upgrade ke alternatif yang aman sesegera mungkin, dan menonaktifkan mundur untuk SSL dan awal TLS dalam rangka untuk memenuhi Payment Card Industry Data Security Standard (PCI DSS) untuk pengamanan data pembayaran.

4.0 Apa artinya bagi saya?

Sejumlah besar situs web dan layanan online akan bermula mematikan dukungan untuk browser dan perangkat lunak yang terhubung ke mereka dengan menggunakan SSL dan awal TLS. Bahkan, tanggal asli yang dikeluarkan untuk migrasi selesai karena bulan April 2015. Namun, Payment Card Industry Security Standards Council (PCI SSC) adalah memperpanjang tanggal ke 30 juni 2018 untuk transisi dari SSL dan TLS 1.0 ke versi aman TLS (saat ini v1.1 atau yang lebih tinggi). Dalam pengertian ini, pedagang dan pelanggan EasyStore mungkin mengalami kesulitan mengakses untuk EasyStore website mulai dari 1 Mei 2018.

Sesiapa yang masih menggunakan SSL dan TLS 1.0 atau di bawah ini akan menggagalkan PCI standar dan oleh karena itu tidak akan diizinkan untuk mengambil pembayaran kartu kredit online. Anda bisa mendapatkan untuk membaca PCI DSS standar secara lengkap di sini.

5.0 Apa resiko?

SSL dan TLS 1.0 rentan terhadap serangan man-in-the-middle , mempertaruhkan integritas dan otentikasi data yang dikirim antara web dan browser. Menonaktifkan SSL dan TLS 1.0 dukungan pada server anda bisa mengurangi masalah ini.

  • Man-in-the-middle attacks: jenis serangan cyber di mana penyerang sisipan dia/dirinya sendiri dalam komunikasi antara dua pihak (orang atau sistem) tanpa salah satu dari mereka yang menyadari hal itu dan relay komunikasi di antara mereka. Sebagai penyerang memiliki akses lengkap untuk komunikasi, ia/dia dapat mencegat, menguping, atau mengubah informasi, dan kemudian mengirim dan menerima komunikasi dari kedua-dua belah pihak. 
  • Setelah pengakhiran SSL dan TLS 1.0, semua koneksi inbound atau outbound koneksi menggunakan protokol tidak akan diterimakan. Oleh itu, semua pengguna dianjurkan untuk mengkonfigurasi server mereka untuk mendukung TLS 1.1 atau di atas.

6.0 Apa yang saya bisa lakukan?

Jika anda tahu bahwa anda menggunakan web browser yang paling up-to-date, keadaan anda dikira OK, namun ada beberapa tools online yang anda bisa gunakan untuk memeriksa keamanan browser anda seperti: https://www.howsmyssl.com. Silakan merujuk ke inline gambar di bawah untuk referensi:

Jika anda menemukan bahwa browser anda tidak aman, maka anda perlu memeriksa untuk melihat apakah anda memiliki versi terbaru diinstal atau beralih ke browser yang berbeda yang menyediakan dukungan untuk TLS 1.1 dan di atas.

Di bawah ini adalah daftar browser populer dan versi yang mendukung TLS 1.1 ke atas.

Did this answer your question?